Contents

1 A simple example 2
2 BVPs in higher dimensions 3
3 Planar elements 5
4 Barycentric coordinates 7
5 The $P_1$ element 7
6 Assembling the linear system 9
7 An optimality property 10
8 The $P_2$ element 10
9 Approximation theory 11
10 Convergence of the FEM 12
11 Nitsche’s trick 13
A Summary of Curvilinear Coordinates 15
B Answers and Hints 16
1 A simple example

1. Consider the BVP from lectures in the special case when \( a(x) = 1 \), that is

\[
\begin{align*}
-u'' &= f(x) \quad \text{for } 0 < x < r, \\
u &= u_\ell \quad \text{at } x = 0, \\
a u' &= \sigma_r \quad \text{at } x = r.
\end{align*}
\]  

(1)

(i) Show that the diagonal entries of the stiffness matrix are given by

\[
A_{ii} = \int_{x_{i-1}}^{x_i} [\phi_i'(x)]^2 \, dx = \frac{1}{h_i} + \frac{1}{h_{i+1}} \quad \text{for } 1 \leq i \leq M - 1,
\]

with

\[
A_{MM} = \int_{x_{M-1}}^{x_M} [\phi_M'(x)]^2 \, dx = \frac{1}{h_M}.
\]

(ii) Show that the off-diagonal entries are

\[
A_{i-1,i} = A_{i,i-1} = \int_{x_{i-1}}^{x_i} \phi_{i-1}'(x)\phi_i'(x) \, dx = -\frac{1}{h_i} \quad \text{for } 2 \leq i \leq M.
\]

2. Let

\[
f_h(x) = \sum_{j=0}^{M} f_j \phi_j(x) \quad \text{where } f_j = f(x_j),
\]

so that \( f_h \) is the continuous piecewise-linear interpolant to \( f \), that is, \( f_h(x_i) = f(x_i) \) for all \( i \). Since \( f_h \approx f \) we can approximate the components of the load vector using

\[
\int_0^r f(x)\phi_i(x) \, dx \approx \int_0^r f_h(x)\phi_i(x) \, dx = \sum_{j=0}^{M} B_{ij} f_j,
\]

where the mass matrix \( B = [B_{ij}] \) is given by

\[
B_{ij} = \int_0^r \phi_j(x)\phi_i(x) \, dx.
\]

(i) Why does \( B_{ij} = 0 \) if \( |i - j| \geq 2 \)?

(ii) Find the diagonal entries \( B_{ii} \) of the mass matrix, for \( 1 \leq i \leq M \).

(iii) Find the off-diagonal entries \( B_{i-1,i} = B_{i,i-1} \) of the mass matrix, for \( 2 \leq i \leq M \).
3. Consider a general, second-order, linear ordinary differential operator

\[ Lu = a(x)u'' + b(x)u' + c(x)u. \]

Find \( A(x), B(x), C(x) \) such that

\[ Lu = -[A(x)u' - B(x)u']' + B(x)u' + C(x)u. \]

4. Consider the 1D boundary value problem

\[-\left( a(x)u' \right)' + a_0(x)u = f(x) \quad \text{for } 0 < x < r, \]
\[ u = u_\ell \quad \text{at } x = 0, \]
\[ au' + bu = \sigma_r \quad \text{at } x = r. \]

(This problem is similar to the one from lectures, but now the ODE and the boundary condition at \( x = r \) have a term in \( u \).) Determine the weak formulation

\[ u \in S \quad \text{and} \quad a(u, v) = \langle \ell, v \rangle \quad \text{for all } v \in T, \]

that is, define \( S, T, a(u, v) \) and \( \langle \ell, v \rangle \).

2 BVPs in higher dimensions

5. The linear partial differential operator

\[ Lu = -\sum_{i=1}^{d} \sum_{j=1}^{d} \partial_i (a_{ij}(x) \partial_j u) \]

is said to be strongly elliptic if there exists a constant \( c > 0 \) such that

\[ \sum_{i=1}^{d} \sum_{j=1}^{d} a_{ij}(x) \xi_i \xi_j \geq c \sum_{j=1}^{n} \xi_j^2 \]

for all \( x \in \Omega \) and \( \xi \in \mathbb{R}^d \).

In other words, \( L \) is strongly elliptic on \( \Omega \) if the matrix \( [a_{ij}(x)] \) is uniformly positive-definite for \( x \in \Omega \). For each of the following examples, determine whether \( L \) is strongly elliptic on the given \( \Omega \).

(i) \( Lu = -\nabla^2 u = \sum_{j=1}^{d} \partial_j^2 u, \) any \( \Omega \subseteq \mathbb{R}^d \).
(ii) \( Lu = \partial_1^2 u - \partial_2^2 u, \) any \( \Omega \subseteq \mathbb{R}^2 \).
(iii) \( Lu = -2\partial_1^2 u + 4\partial_1\partial_2 u - 3\partial_2^2 u, \) any \( \Omega \subseteq \mathbb{R}^2 \).
(iv) \( Lu = -\partial_1^2 u + \partial_2 [(x_2 - 2x_1)\partial_2 u] \), \( \Omega \) is the disk with center \((2, 0)\) and radius 1.

(v) \( Lu = -\partial_1^2 u + \partial_2 [(x_1 - 2x_2)\partial_2 u] \), \( \Omega \) is the unit square \((0, 1) \times (0, 1)\).

6. The heat equation for an anisotropic material is

\[
\frac{\partial u}{\partial t} + Lu = f,
\]

where \( L \) has the form (2). To derive this PDE, we apply conservation of thermal energy, assuming that the heat flux vector \( \mathbf{q} = [q_1, q_2, q_3]^T \) has components given by

\[
q_i = -\sum_{j=1}^{3} a_{ij} \partial u_j,
\]

so that \( Lu = \text{div} \mathbf{q} = \nabla \cdot \mathbf{q} \). Give a physical reason why we expect \( L \) to be strongly elliptic.

7. Determine the weak formulation,

\[
u \in S \quad \text{and} \quad a(u, v) = \langle \ell, v \rangle \quad \text{for all} \quad v \in T,
\]

for the boundary value problem

\[
-\sum_{i=1}^{d} \sum_{j=1}^{d} \partial_i (a_{ij} \partial_j u) + a_0(x)u = f(x) \quad \text{in} \ \Omega, \quad u = g_D \quad \text{on} \ \Gamma_D, \quad \sum_{i=1}^{d} \nu_i \sum_{j=1}^{d} a_{ij} \partial_j u + bu = g_N \quad \text{on} \ \Gamma_N.
\] (3)

Here we say that \( u \) satisfies a Robin boundary condition on \( \Gamma_N \), and we call \( \sum_{i=1}^{d} \nu_i \sum_{j=1}^{d} a_{ij} \partial_j u \) the conormal derivative of \( u \).

8. Prove that if \( L \) is strongly elliptic on \( \Omega \), and if \( a_0(x) \geq 0 \) and \( b(x) \geq 0 \) for all \( x \in \Omega \), then the weak solution of the BVP (3) is unique (assuming \( u \) exists).
3 Planar elements

We will use a mesh generation and visualization program called

http://www.geuz.org/gmsh/.

This program is free (GPL) software and runs on Windows, Mac OS X and Linux.

9. Follow the instructions below to generate the mesh shown in Figure 1.

(i) Start gmsh in interactive mode. Do Help > Mouse Actions to open the message console window, and note how you can rotate, pan and zoom. Keep this window open and observe the messages displayed as we create various objects.

(ii) From the Gmsh control window, do Tools > Options to open the Options window. Make sure General is highlighted in the (left) side pane, select the Axes tab, change the Axes mode to Open grid and uncheck the Set position and size of axes automatically and Show small axes boxes. You should now see an axis grid. Set the
Axes labels to X, Y, Z and set the Axes minimum to −1 for the X and Y axes.

(iii) Make sure that the Gmsh control window is set to the Geometry module, then do Elementary entities > Add > New > Point. Follow the onscreen instructions to add points at (−1, 1), (−1, −1), (1, −1), (1, 0), (1, 1) and (0, 1).

(iv) In the Options window, select Geometry in the side pane, and in the Visibility tab tick the checkbox for Point numbers. You should see your points numbered from 1 to 6. Back in the Gmsh control window, click on Straight line and follow the onscreen instructions to add line segments from points 6 to 1, 1 to 2, 2 to 3 and 3 to 4. Note that you can use the small triangular arrows to the left of the module name to step forwards and backwards through the menus.

(v) Now add a Circle arc with start point 4, centre point 5 and end point 6. You should now have a closed curve defining the boundary of a surface in the XY-plane. Set the Axes mode back to None.

(vi) Add a Plane surface.

(vii) Step back in the menu and select Physical groups > Add > Line. Follow the onscreen instructions to select the line segments from points 1 to 2 and 2 to 3. End this selection and make a second selection consisting of the line segments from points 3 to 4 and 6 to 1. Then make a third selection consisting of the circular arc from 4 to 6.

(viii) Add a Surface physical group.

(ix) Do File > Save As and save to a file roundL.geo, accepting the option to “save physical group labels”.

(x) Do File > Quit to close gmsh, and then use a text editor (such as geany) to examine the contents of roundL.geo. You may find it simpler to create such a file manually instead of using the gmsh GUI.

10. We will now mesh the domain defined by the geometry file roundL.geo constructed above.

(i) Start gmsh in interactive mode, do File > Open and select the file roundL.geo.

(ii) In the gmsh control window, select the Mesh module.

(iii) Do Tools > Options to open the options window, and in the left pane select Mesh. Tick the Nodes checkbox.
(iv) Back in the control window, select 1D. You should see mesh nodes appear around the boundary of the surface.

(vi) Now select 2D. Gmsh constructs a surface triangulation tied to the boundary nodes. You may wish to tick the Surface faces checkbox in the Visibility tab of the options window.

(vii) Do File > Save Mesh to create a file roundL.msh. Use a text editor to examine the contents of this mesh file. The gmsh manual describes the file format in Chapter 9.

(vii) Select Refine by splitting to obtain a finer mesh. You should now see the image in Figure 1.

4 Barycentric coordinates

11. Prove that \((A^{-1})^T = (A^T)^{-1}\) for any non-singular matrix \(A\).

12. Show that for \(i \in \{1, 2, 3\}\) and \(j \in \{1, 2\}\),

\[
\frac{\partial \psi_{ki}}{\partial x_j} = b_{ji} \quad \text{if} \quad b_i = \begin{bmatrix} b_{1i} \\ b_{2i} \end{bmatrix}.
\]

13. Let \(m, n\) and \(p\) be non-negative integers.

(i) Use integration by parts to show that

\[
\int_0^a \frac{t^m}{m!} \frac{(a-t)^n}{n!} dt = \frac{a^{m+n+1}}{(m+n+1)!}.
\]

(ii) Hence show that

\[
\int_0^1 \int_0^{1-x} (1-x-y)^m x^n y^p dy dx = \frac{m!n!p!}{(m+n+p+2)!}.
\]

5 The \(P_1\) element

14. Let \(\Delta(z_1, z_2, z_3)\) be the right-angled triangle with vertices

\[z_1 = (h_1, 0), \quad z_2 = (0, h_2), \quad z_3 = (0, 0)\].

(i) Find the matrix \(B = [z_1 - z_3 \quad z_2 - z_3]^{-T} \in \mathbb{R}^{2\times 2}\).

(ii) Write down the vectors \(b_1, b_2\) and \(b_3\).
(iii) Hence find the barycentric coordinates $\lambda_1$, $\lambda_2$ and $\lambda_3$ as functions of $x = (x_1, x_2)$.

(iv) Compute the entries of $P_1$ element stiffness matrix

$$a_{pq} = \int_{\triangle} \nabla \lambda_p \cdot \nabla \lambda_q, \quad \text{for } p, q \in \{1, 2, 3\}.$$ 

15. Consider the mesh shown in Figure 2, where we use thicker line segments to indicate the parts of the boundary where an essential boundary condition is required. The node numbers are shown in ordinary type, and the element numbers are in bold italic.

(i) What is $M$, the number of elements?

(ii) What is $N$, the number of nodes?

(iii) What is $N_f$, the number of degrees of freedom?

(iv) Give an $M \times 3$ connectivity matrix $C = [C_{kp}]$ for this mesh. Recall that $C_{kp}$ is the global node number of the $p$th node in the $k$ element. Thus, in each triangle you will have to decide how to label the nodes 1, 2, 3 (counter-clockwise).

16. Compute the entries of the $P_1$-element mass matrix,

$$\int_{\triangle_k} \psi_{kp} \psi_{kq} \quad \text{for } p, q \in \{1, 2, 3\}.$$ 

8
6 Assembling the linear system

17. Let $A = [a_{ij}] \in \mathbb{R}^{N \times N}$ denote the global matrix for a given bilinear form, and let $A^{(k)} \in \mathbb{R}^{3 \times 3}$ $(1 \leq k \leq M)$ denote the associated element matrices. For the mesh shown in Figure 2, and your chosen connectivity matrix (see Exercise 5.15), express each of the following entries of $A$ as a sum of entries of the element matrices.

$a_{11}$, $a_{34}$, $a_{45}$, $a_{67}$, $a_{7,14}$, $a_{8,10}$.

18. Download the files roundL.geo and poisson.py from Moodle.

(i) Use the command

```
gmsh -2 -optimize_lloyd -o roundL.msh roundL.geo
```

to create the mesh file roundL.msh. (Type `gmsh --help` for an explanation of the command-line options.)

(ii) Do `gmsh roundL.msh &` to start the GUI and view the mesh. Then click `Tools > Options`, select `Mesh` in the left side pane, tick `Line Labels` and choose `Physical group` from the drop-down menu for the `Label type`. You should now see all the boundary edges labelled as 1, 2 or 3, as defined in `roundL.geo`.

(iii) We will use FEniCS to solve the boundary value problem

$$-
\nabla^2 u = 1 \quad \text{in } \Omega,
\partial_\nu u = -2 \quad \text{on } \Gamma_1,
\quad u = 2 \quad \text{on } \Gamma_2,
\partial_\nu u = 0 \quad \text{on } \Gamma_3,
$$

where $\Omega$ is planar region triangulated by the mesh, and $\Gamma_i$ is the part of $\partial \Omega$ labelled by $i$. First do

```
dolfin-convert roundL.msh roundL.xml
```

to generate XML files that describe the mesh in a format understood by Dolfin (the FEniCS component that we use directly), and then type

```
python poisson.py
```

(iv) Study the Python code in `poisson.py` in conjunction with the documentation at

`http://fenicsproject.org/documentation/`
(v) Try changing the Dirichlet boundary condition to \( u = 1 + xy \).
You will need to read the documentation for a Dolfin Expression class.

(vi) Solve the boundary value problem using a finer mesh, by doing

\[
gmsh -2 -clmax 0.075 -o roundL.msh roundL.geo
\]

7 An optimality property

19. Consider the bilinear form arising in the weak formulation of (3),

\[
a(u, v) = \int_\Omega \sum_{i,j=1}^d a_{ij} \partial_i u \partial_j v + \int_\Omega a_0 uv + \int_{\Gamma_N} b uv.
\]

(i) Show that there exists a constant \( C \) such that

\[
|a(u, v)| \leq C \|u\|_{H^1(\Omega)} \|v\|_{H^1(\Omega)} \quad \text{for all } u, v \in H^1(\Omega). \tag{4}
\]

You may assume the following version of the trace theorem,

\[
\int_{\Gamma_N} |v|^2 \leq C \|v\|_{H^1(\Omega)}^2 \quad \text{for all } v \in H^1(\Omega).
\]

(ii) Formulate some sufficient conditions to ensure the existence of a constant \( c > 0 \) such that

\[
a(v, v) \geq c \|v\|_{H^1(\Omega)}^2 \quad \text{for all } v \in H^1(\Omega). \tag{5}
\]

(iii) Show that, when (4) and (5) hold, the energy norm is equivalent to the norm in \( H^1(\Omega) \).

8 The \( P_2 \) element

20. Prove that if \( f \) and \( g \) are polynomials in \( x \in \mathbb{R} \) of degree at most \( r \), and if there exist \( r + 1 \) distinct points \( x_1, x_2, \ldots, x_{r+1} \) such that

\[
f(x_p) = g(x_p) \quad \text{for all } p \in \{1, 2, \ldots, r + 1\},
\]

then \( f(x) = g(x) \) for all \( x \in \mathbb{R} \). [Hint: use the fundamental theorem of algebra.]
21. Since \( \text{dim } \mathbb{P}_3 = 4 + 3 + 2 + 1 = \frac{1}{2}(5)(4) = 10 \) the \( P_3 \) element requires 10 nodes.

(i) How many nodes do we need on each edge to ensure global continuity?

(ii) Define appropriate \( z_{kp} \) for \( 4 \leq p \leq 10 \).

(iii) Find the shape functions \( \psi_{kp}(x) \) for \( 1 \leq p \leq 10 \) such that \( \psi_{kp} \in \mathbb{P}_3 \) and

\[
\psi_{kp}(z_{kq}) = \delta_{pq} \quad \text{for } 1 \leq p \leq 10 \text{ and } 1 \leq q \leq 10.
\]

(iv)* How can we extend this construction to obtain a \( P_r \) element for any positive integer \( r \)?

22. Consider the bilinear form \( a(u,v) = \int_{\Omega} \nabla u \cdot \nabla v \). Compute the entries of the \( P_2 \)-element stiffness matrix,

\[
a^k_{pq} = \int_{\Delta_k} \nabla \psi_{kp} \cdot \nabla \psi_{kq} \quad \text{for } 1 \leq p \leq 6 \text{ and } 1 \leq q \leq 6.
\]

23. Compute the entries of \( P_2 \)-element mass matrix,

\[
\int_{\Delta_k} \psi_{kp} \psi_{kq} \quad \text{for } 1 \leq p \leq 6 \text{ and } 1 \leq q \leq 6.
\]

9 Approximation theory

24. If \( t > d/2 \) then we have the Sobolev imbedding \( H^t(\Omega) \subseteq C(\overline{\Omega}) \). Show that this imbedding can fail to hold if \( t = d/2 \) by verifying that in \( d = 2 \) dimensions the unbounded function

\[
v(x) = \log \log(2/|x|)
\]

belongs to \( H^1(\Omega) \) for \( \Omega = \{ x \in \mathbb{R}^2 : |x| < 1 \} \).

25. Consider the piecewise-linear interpolation operator in 1D:

\[
I_k v(x) = \frac{(x_i - x)v(x_{i-1}) + (x - x_{i-1})v(x_i)}{h_i} \quad \text{for } x_{i-1} \leq x \leq x_i,
\]

for a grid \( 0 = x_0 < x_1 < x_2 < \cdots < x_M = 1 \).
(i) Verify that
\[(v - \text{I}_h v)(x) = \int_{x_{i-1}}^{x_i} K_i(x, t)v''(t) \, dt \quad \text{for} \quad x_{i-1} \leq x \leq x_i,
\]
where the Peano kernel is given by
\[K_i(x, t) = (x - t)_+ - h_i^{-1}(x - x_{i-1})(x_i - t).
\]
Hint: integrate by parts on the RHS.

(ii) Hence find a constant \(C_0\) such that
\[\int_{x_{i-1}}^{x_i} (v - \text{I}_h v)^2 \, dx \leq C_0^2 h_i^4 \int_{x_{i-1}}^{x_i} (v'')^2 \, dx,
\]
Hint: apply the Cauchy–Schwarz inequality and use the substitutions \(x = x_{i-1} + \xi h_i\) and \(t = x_{i-1} + \tau h_i\).

(iii) Deduce that \(\|v - \text{I}_h v\|_{0, \Omega} \leq C h^2 |v|_{2, \Omega}\) where \(\Omega = (0, 1)\).

(iv) Find a constant \(C_1\) such that
\[\int_{x_{i-1}}^{x_i} \left[ v' - (\text{I}_h v)' \right]^2 \, dx \leq C_1^2 h_i^2 \int_{x_{i-1}}^{x_i} (v'')^2 \, dx,
\]
(v) Deduce that \(\|v - \text{I}_h v\|_{1, \Omega} \leq C_1 h |v|_{2, \Omega}\).

10 Convergence of the FEM

26. Recall that in our weak formulation of the mixed boundary value problem,
\[\langle \ell, v \rangle = \int_{\Omega} f v + \int_{\Gamma_N} g_N v.
\]
In the FEM, we compute \(\langle \ell, \phi_i \rangle\) for \(1 \leq i \leq N_i\), usually by adding up the contributions from each element. To avoid the need to evaluate the integrals
\[\int_{x \in \Delta_k} f(x)\psi_{kp}(x) \quad \text{and} \quad \int_{x \in \Gamma_k} g_N(x)\tilde{\psi}_{kp}(x),
\]
we may approximate \(\langle \ell, v \rangle\) by
\[\langle \ell_h, v \rangle = \int_{\Omega} (I_h f)v + \int_{\Gamma_N} (I_h g_N)v,
\]
in other words, we replace \(f\) and \(g_N\) by their interpolants \(I_h f\) and \(I_h g_N\).
(i) Explain how to compute $\langle \ell_h, \phi_i \rangle$ from a knowledge of the mass matrices

$$\int_\Omega \phi_j \phi_i \quad \text{and} \quad \int_{\Gamma_N} \phi_j \phi_i.$$ 

(ii) Let $U_h \in S_h$ denote the solution of the perturbed FEM

$$a(U_h, v) = \langle \ell_h, v \rangle \quad \text{for all } v \in T_h.$$ 

Show that

$$\|U_h - u_h\|_{1,\Omega} \leq C \|I_h f - f\|_{\Omega} + C \|I_h g_N - g_N\|_{\Gamma_N}.$$ 

(iii) Deduce that $U_h$ achieves the same convergence rate as $u_h$ in the $H^1$-norm, provided $u$ is sufficiently smooth.

11 Nitsche’s trick

27. Let

$$Lu = -\sum_{i=1}^d \sum_{j=1}^d \partial_i (a_{ij} \partial_j u) + a_0 u,$$

$$L^* v = -\sum_{i=1}^d \sum_{j=1}^d \partial_i (a_{ji} \partial_j v) + a_0 v.$$ 

We define the bilinear form

$$a(u, v) = \int_\Omega \sum_{i=1}^d \sum_{j=1}^d a_{ij} \partial_j u \partial_i v + \int_{\Omega} a_0 u v,$$

and the conormal derivatives

$$B_{\nu} u = \sum_{i=1}^d \nu_i a_{ij} \partial_j u \quad \text{and} \quad B_{\nu} v = \sum_{i=1}^d \nu_i a_{ji} \partial_j v.$$ 

Use the divergence theorem to show that

$$\int_\Omega u (L^* v) + \int_{\partial \Omega} u B_{\nu} v = a(u, v) = \int_\Omega (Lu) v + \int_{\partial \Omega} (B_{\nu} u) v.$$ 

28. Let $\Omega$ be the 2D sector given in polar coordinates by $0 < r < 1$ and $0 < \theta < \alpha$, for a given angle $\alpha \in (0, 2\pi)$. 

13
(i) Let \( n \in \{1, 2, 3, \ldots\} \), and show that the function

\[
u_n = r^{n\pi/\alpha} \sin(n\pi\theta/\alpha)\]

satisfies the boundary value problem

\[
\begin{align*}
\nabla^2 u_n &= 0 & \text{for } 0 < r < 1 \text{ and } 0 < \theta < \alpha, \\
u_n &= 0 & \text{for } 0 < r < 1 \text{ and } \theta = 0, \\
u_n &= 0 & \text{for } 0 < r < 1 \text{ and } \theta = \alpha, \\
u_n &= \sin(n\pi\theta/\alpha) & \text{for } r = 1 \text{ and } 0 < \theta < \alpha.
\end{align*}
\]

(ii) Verify that \( u_n \in H^1(\Omega) \).

(iii) Verify that \( u_n \in H^2(\Omega) \) if \( 0 < \alpha \leq \pi \).

(iv) Verify that \( u_1 \notin H^2(\Omega) \) if \( \pi < \alpha < 2\pi \).

29. With the notation of Exercise 10.26, show that

\[
\|U_h - u_h\|_{\Omega} \leq C \|I_h f - f\|_{\Omega} + C \|I_h g_N - g_N\|_{\Gamma_N}.
\]

What do you conclude about the accuracy of \( U_h \) in the \( L_2 \)-norm?
A Summary of Curvilinear Coordinates

Assumptions: \((x_1, x_2, x_3) = \Phi(\xi_1, \xi_2, \xi_3)\) such that
\[
\frac{\partial(x_1, x_2, x_3)}{\partial(\xi_1, \xi_2, \xi_3)} > 0 \quad \text{and} \quad \frac{\partial x_i}{\partial \xi_i} \cdot \frac{\partial x_j}{\partial \xi_j} = 0 \quad \text{whenever} \quad i \neq j.
\]
Scale factors and unit vectors:
\[
h_i = h_{\xi_i} = \left| \frac{\partial \mathbf{x}}{\partial \xi_i} \right| \quad \text{and} \quad e_{\xi_i} = \frac{1}{h_i} \frac{\partial \mathbf{x}}{\partial \xi_i} \quad (\text{no sum over} \ i)
\]
Right-handed orthonormal basis:
\[
e_{\xi_i} \cdot e_{\xi_j} = \delta_{ij} \quad \text{and} \quad e_{\xi_i} \times e_{\xi_j} = \epsilon_{ijk} e_{\xi_k}.
\]
Metric:
\[
ds^2 = h_1^2 d\xi_1^2 + h_2^2 d\xi_2^2 + h_3^2 d\xi_3^2.
\]
Vector line element:
\[
d\mathbf{x} = h_1 d\xi_1 e_{\xi_1} + h_2 d\xi_2 e_{\xi_2} + h_3 d\xi_3 e_{\xi_3}.
\]
Vector surface element: for \(\mathbf{x} = \mathbf{x}(u, v),\)
\[
dS = \frac{\partial \mathbf{x}}{\partial u} \times \frac{\partial \mathbf{x}}{\partial v} \ du \ dv = \det \begin{bmatrix} e_{\xi_1} & e_{\xi_2} & e_{\xi_3} \\
\frac{\partial \xi_1}{\partial u} & h_1 & h_2 \\
\frac{\partial \xi_2}{\partial u} & h_2 & h_3 \\
\frac{\partial \xi_3}{\partial u} & h_3 & h_1 \end{bmatrix} \ du \ dv.
\]
Volume element:
\[
dV = h_1 h_2 h_3 \ d\xi_1 \ d\xi_2 \ d\xi_3.
\]
Gradient:
\[
\nabla f = \frac{1}{h_1} \frac{\partial f}{\partial \xi_1} e_{\xi_1} + \frac{1}{h_2} \frac{\partial f}{\partial \xi_2} e_{\xi_2} + \frac{1}{h_3} \frac{\partial f}{\partial \xi_3} e_{\xi_3}.
\]
Divergence:
\[
\nabla \cdot \mathbf{F} = \frac{1}{h_1 h_2 h_3} \left( \frac{\partial}{\partial \xi_1} (h_2 h_3 F_{\xi_1}) + \frac{\partial}{\partial \xi_2} (h_3 h_1 F_{\xi_2}) + \frac{\partial}{\partial \xi_3} (h_1 h_2 F_{\xi_3}) \right).
\]
Curl:
\[
curl \mathbf{F} = \frac{1}{h_1 h_2 h_3} \det \begin{bmatrix} h_1 e_{\xi_1} & h_2 e_{\xi_2} & h_3 e_{\xi_3} \\
\frac{\partial}{\partial \xi_1} & \frac{\partial}{\partial \xi_2} & \frac{\partial}{\partial \xi_3} \\
h_1 F_{\xi_1} & h_2 F_{\xi_2} & h_3 F_{\xi_3} \end{bmatrix}.
\]
B Answers and Hints

2. (ii) $B_{ii} = (h_i + h_{i+1})/3$ for $1 \leq i \leq M - 1$, and $B_{MM} = h_M/3$.
(iii) $B_{i-1,i} = h_i/6$

4. $S := \{ v \in H^1(\Omega) : v(0) = u_\ell \}$.
$T := \{ v \in H^1(\Omega) : v(0) = 0 \}$, $a(u, v) := \int_0^r (au'v' + a_0uv) \, dx + bu(r)v(r)$,
$\langle \ell, v \rangle := \int_0^r f v \, dx + \sigma v(r)$.

5. (i) yes (ii) no (iii) yes (iv) yes (v) no

7. $S = \{ v \in H^1(\Omega) : v = g_D \text{ on } \Gamma_D \}$, $T = \{ v \in H^1(\Omega) : v = 0 \text{ on } \Gamma_D \}$,
$a(u, v) = \int_{\Omega} \sum_{i,j=1}^d a_{ij} \partial_i u \partial_j v + \int_{\Omega} a_0 uv + \int_{\Gamma_N} b u v$,
$\langle \ell, v \rangle = \int_\Omega fv + \int_{\Gamma_N} g_N v$

14. (i) $B = \begin{bmatrix} 1/h_1 & 0 \\ 0 & 1/h_2 \end{bmatrix}$
(ii) $b_1 = \begin{bmatrix} 1/h_1 \\ 0 \end{bmatrix}$, $b_2 = \begin{bmatrix} 0 \\ 1/h_2 \end{bmatrix}$, $b_3 = \begin{bmatrix} -1/h_1 \\ -1/h_2 \end{bmatrix}$
(iii) $\lambda_1 = x_1/h_1$, $\lambda_2 = x_2/h_2$, $\lambda_3 = 1 - x_1/h_1 - x_2/h_2$
(iv) $[a_{pq}] = \begin{bmatrix} \alpha & 0 & -\alpha \\ 0 & \beta & -\beta \\ -\alpha & -\beta & \alpha + \beta \end{bmatrix}$ where $\alpha = \frac{h_1}{h_2}$ and $\beta = \frac{h_2}{h_1} = \frac{1}{\alpha}$.

15. (i) $M = 15$ (ii) $N = 14$ (iii) $N_1 = 8$

25. (ii) $C_0^2 = \frac{1}{6} \int_0^1 \xi^2(1 - \xi)^2 \, d\xi = 1/90$ (iv) $C_1^2 = \frac{2}{3} \int_0^1 \xi^3 \, d\xi = 1/6$